Excel'de Etopla işlevi ile şarta bağlı toplam almak

Excel'de Etopla işlevi ile şarta bağlı toplam almak

Excel'de tek şarta bağlı toplam almak için ETOPLA işlevini nasıl kullanırız.

Excel'de en sık kullanılan işlevlerin başında gelen ETOPLA işlevini kullanarak şarta bağlı toplam aldırabilirsiniz.  

ETOPLA işlevinin kullanımı aşağıdaki gibidir. 

=ETOPLA(aralık; ölçüt; [toplam_aralığı])

ETOPLA işlevinin söz diziminde aşağıdaki bağımsız değişkenler bulunur:

 

Aralık: Ölçüte göre değerlendirilmesini istediğiniz hücre aralığı. Aralıklardaki hücrelerde numaralar veya adlar, diziler ya da sayı içeren başvurular bulunmalıdır. Boşluk ve metin değerleri yoksayılır. Seçilen aralık standart Excel biçiminde tarihler içerebilir.
 
Ölçüt: Hangi hücrelerin sayılacağını tanımlayan sayı, ifade, hücre başvurusu, metin ya da hangi hücrelerin toplanacağını tanımlayan bir işlev biçimindeki ölçüt. Örneğin, ölçüt 32, ">32", B5, "32", "elmalar" veya BUGÜN() olarak gösterilebilir.
 
Önemli: Tüm metin ölçütleri ve mantıksal ya da matematiksel simge içeren ölçütler çift tırnak (") içine alınmalıdır. Ölçüt sayısal bir değerse, çift tırnak kullanmak gerekmez.
 
Toplam_aralığı: Aralık bağımsız değişkeninde belirtilen hücrelerden farklı hücrelerin toplamını almak istiyorsanız, toplamı alınacak hücreler. Toplam_aralığı bağımsız değişkeni belirtilmezse, Excel aralık bağımsız değişkeninde belirtilen hücreleri toplar (bunlar, ölçütün uygulandığı hücrelerdir).

Ölçüt bağımsız değişkeni olarak soru işareti (?) ve yıldız işareti (*) gibi joker karakterler kullanabilirsiniz. Soru işareti tek karakterle eşleşirken yıldız işareti herhangi bir karakter dizisiyle eşleşir. Gerçek bir soru işaretini veya yıldız işaretini bulmak istiyorsanız, karakterden önce bir tilde işareti (~) koyun.

Bir rakam grubunun bulunduğu aralıkta =ETOPLA(B2:F11;">=5000") formülünü uyguladığınızda, B2:F11 aralığındaki değerlerin 5000'den yukarı olan değerlerinin toplamını alırsınız.  

ETOPLA işlevini farklı sütunlarda kullanmak isterseniz, =ETOPLA(B:B;"Humanica";C:C) formülünü uygulayabilirsiniz.  B sütunundaki Humanica değerini bulur ve C sütunundaki karşılığını toplayabilirsiniz.

İsterseniz, ölçütü bir aralığa uygulayıp farklı bir aralıkta bunlara karşılık gelen değerlerin toplamını alabilirsiniz. Örneğin, =ETOPLA(B2:B5, "Humanica", C2:C5) formülü yalnızca C2:C5 aralığında yer alan ve B2:B5 aralığındaki ilişkili hücrelerin "Humanica" değerine eşit olduğu değerlerin toplamını alır.

Excel'de Etopla işlevi kullanım eğitim videolarına göz atın.

Etopla işlevinini iki farklı şart için aşağıdaki gibi kullanabilirsiniz. 

 
=ETOPLA(C:C;"Humanica";D:D)+ETOPLA(C:C;"Fernas Enerji";D:D)

Bu listede Humanica ve Fernas Enerji'nin D sütunundaki değerleri toplanır. İki tane Etopla kullanmak yerine, bunu tek bir Etopla işlevi ile de çözebiliriz.
 
=TOPLA(ETOPLA(B:B;{"Humanica";"Fernas Enerji"};C:C))

 

Bu makale 240 kişi tarafından okundu