Excel'de Eğer, Ve, İç İçe Eğer, Çokeğer işlevi kullanım örnekleri

Excel'de Eğer, Ve, İç İçe Eğer, Çokeğer işlevi kullanım örnekleri

Excel'in en çok kullanılan Eğer İşlevi, VE işlevi, İç İçe Eğer ve Excel 2016'daki Çokeğer işlevi kullanım örnekleri

Excel'i kullanıyorsanız mutlaka şarta bağlı hesaplama yapma ihtiyacı duyarsınız. Excel'de yoğun olarak kullanılan Eğer işlevinin kullanımına ihtiyaç duyarsınız. 

EĞER İşlevi, bir koşula bağlı değerleri hesaplamak için kullanılır.

Eğer İşlevi Topla, Ortalama İşlevi gibi oldukça yaygındır. Eğer fonksiyonu tek başına kullanabileceğiniz gibi, iç içe, VE, YADA işlevleri ile birlikte kullanabilirsiniz.
İç içe Eğer fonksiyonunu kullanırken dikkat etmeniz gereken noktalar;
  • Kaç tane Eğer ifadesi kullandıysanız, en sonda o kadar parantez kapatmanız gerekir.
  • Eğer Fonksiyonunu kullanırken, ilk hücrenin şarta uygun olup, olmadığına bakmadan ilk hücreden başlamak gerekir.
  • Eğer işlevinde Temsilci İsmi, Ürün İsmi, Firma İsmi gibi sayısal olmayan ifadeler yazdırmanız gerekirse bu tür metinsel ifadeler tırnak işareti içinde yazılmalıdır.
İşlevin genel kullanımı: 
=EĞER(Şart;Şart_doğruysa_değer;Şart_yanlışsa_değer) şeklindedir.
Burada:
Şart; sizin belirlediğiniz şarttır.
Şart_doğruysa_değer; Verdiğiniz şartın sağlanması durumunda yazılacak olan değerdir.
Şart_yanlışsa_değer; Verilen şartın sağlanmaması durumunda yazılacak olan değerdir.
Örnek:

Örneğin A6 hücresinde 15 değeri olsun. Eğer A6 hücresindeki değere göre hesaplatma yapmak isterseniz Eğer Fonksiyonunu aşağıdaki gibi kullanmanız gerekir.
=EĞER(A6>20;A6*20%;A6*10%)
Burada Excel ilk olarak A6 hücresindeki değere bakar, eğer A6 hücresinde bir rakam varsa İşlevin içinde verilen şarta bakılır. A6’daki değer 20 değerinden küçük olduğu için bizim şartımız sağlanmaz. O zaman A6*10% kısmı geçerli olur.


Excel'de Eğer, İç İçe Eğer, Eğer VE, Eğer YADA işlevi kullanım örnekleri.
Excel'de Eğer, Ve, YADA işlevleri farklı alanlarda ve farkı örnekler üzerinde aşağıdaki gibi kullanılabilir.  Genelleme olarak, 
- Tek sütunda, tek bir şarta göre hesaplama yapılacaksa EĞER işlevi kullanılır.
Bknz: Excel'de Eğer İşlevi nasıl kullanılır?
- Birden fazla sütunda şarta bağlı hesaplama yapmak için İç İçe Eğer işlevi, yada Excel 2016 ve Excel 365 'de ÇOKEĞER işlevi kullanılır.
Bknz: Excel'de İç İçe Eğer İşlevi nasıl kullanılır? 
Bknz: Excel de ÇOKEĞER İşlevi nasıl kullanılır?

- Farklı sütunlarda işlemler yapacaksanız, Eğer ve VE, YADA işlevleri iç içe kullanılır. 
Bknz: Excel'de Eğer ve VE işlevi kullanımı nasıldır?

Bknz: Excel'de YADA işlevi nasıl kullanılır?
---
Excel Eğer Kullanım Örnekleri- vidoport
A2 deki tarihin gün değerini 21 'den büyük ise E2 değerinin %2 fazlasını, Eğer gün değeri 21 den küçük ise %1 fazlasını bulan Excel Eğer formülü
---
Excel Eğer Kullanım Örnekleri- vidoport
KDV oranı 18’e eşit olan ve Fiyat değeri 10000’den büyük olan satırların satış değerini getirtmek için Eğer ve VE formüllerini yukarıdaki gibi kullanırız.
---
Excel Eğer Kullanım Örnekleri- vidoport
Yukarıdaki tabloda Fernas Enerji ve NTG Nakliyat firmalarının fiyat değerlerini bulmak için Eğer ve YADA işlevlerini yukarıdaki gibi kullanırız.
---
Excel Eğer Kullanım Örnekleri- vidoport
Fernas Enerjinin 20000’ni geçen satış değerlerini getirtmek için; Eğer ve Ve formülünü yukarıdaki gibi kullanılırız.
---
Excel Eğer Kullanım Örnekleri- vidoport
C2 değeri Anadolum’a eşit ise D2 ‘deki değerin %3’nü, C2 değeri Eku Fren ise D2’deki değerin %5’ni, bu iki firmanın dışındaki firmalar için ise, D2 değerinin %15’ni bulan ÇOKEĞER formülünü yukarıdaki gibi kullanabiliriz.
---
Excel Eğer Kullanım Örnekleri- vidoport
D2 hücresindeki değere göre, 20000’den küçük olan değerlerin %1’ni, 30000 den küçük eşit olan değerlerin %2’sini, 30000 den büyük olan değerlerin %5’ni bulan ÇOKEĞER formülünü yukarıdaki gibi kullanabiliriz.
---
Excel'de Eğer işlevi kullanım örnekleri
Anadolum firmasının satışlarına %3, Eku Fren Satışlarına %5, bu iki firma dışındaki firmalara %15 prim veren İç İçe Eğer formülü yukarıdaki gibi kullanılır.

 

Bu makale 378 kişi tarafından okundu